Problems importing scripts

Discuss how to use this leading screenplay formatting software. Have a tip? Question? Post it here and share ideas.

Problems importing scripts

Postby ChasBelov » Nov 27, 2010 3:04 am

I am considering purchase of Movie Magic Screenwriter 6 but am having troubles with the trial version I downloaded to my Intel Mac running Snow Leopard. You may have seen the crash reports that just went to Apple.

I have been editing my scripts in, but would like to take advantage of the features of MMS6, particularly the ability to have it read the parts in different voices and to automatically break dialog in appropriate places and add continueds automatically. Features that distinguish MMS6 from Final Draft and make it my preferred choice are that I can undo a Replace All with a single undo, that I can highlight a single character (although I would rather be able to do it with yellow highlighting instead of red text and underline), and that I can edit text that is in dual columns without having to de-dual it.

But I am running into some problems that prevent me from confidently whipping out my credit card.

In OpenOffice, I converted the styles to use the same names that MMS6 uses for elements (Action, etc.), then saved the file as .rtf. But during import, when I check Use Stylesheets and Action is in Parentheticals and uncheck Use Most Agressive, much of the content loses the styles I set. Notes become Action or Dialog. Some Action becomes Character Name. Some Character Name becomes part of the following line Dialog, losing the paragraph break. Some Parenthetical becomes Dialog, etc.

Worse, all paragraphs get prefixed by \s0 or \S0. Also, some Actions wind up with a (( and )) instead of ( and ). When so paired, the outer () is not editable and the inner () are. But if I try to do a series of replace all, \s0 with a null string, \S0 with a null string, ( with a null string followed by ) with a null string, that last operation leads to the application not responding. I wind up having to force quit.

If I instead chose Use Most Aggressive instead of Use Stylesheets, all the Action becomes Parenthetical.

Can you shed some light on the import process and what might be causing this problem?

Note: This is a stage play and I am using approximately the Dramatists Guild traditional stage play format as my default format, and also tried the modern format to no avail.

I have verified that Writer is exporting Rich Text Format with the stylesheet, including the appropriate style names, for example:

{\*\hyphen2\hyphlead2\hyphtrail2\hyphmax0}\aspalpha\ql\rtlch\af13\afs24\lang1033\ltrch\dbch\af9\langfe1033\hich\f3\fs24\lang2057\loch\f3\fs24\lang2057\sbasedon24\snext16 Action;}


{\s31{\*\hyphen2\hyphlead2\hyphtrail2\hyphmax0}\aspalpha\ql\rtlch\af12\afs24\lang1033\ltrch\dbch\af12\langfe1033\hich\f3\fs24\lang2057\loch\f3\fs24\lang2057\snext31 Note;}


Re: Problems importing scripts

Postby ChasBelov » Nov 28, 2010 6:53 pm

This is a follow-up on my previous post.

First off, the problem with the double parentheses occurs with parentheticals that are imported but not identified by the importing logic as being parentheticals. That is, they are identified as Dialog or Action. When I click in the mis-identified parenthetical and choose Parenthetical from the drop-down, MMS6 adds its own parentheses but does not remove the parentheses that were already in the script. These now-extra parentheses have to be removed manually, as MMS6 find-and-replace will not let me Replace All these extra ( or ) symbols with nothing; it claims not to find any.

I've tried to upload an example problem document, but the forum won't allow me to upload a Rich Text Format (RTF) file. Here is my experience with the document which I am importing into Movie Magic Screenwriter (r6):

The RTF file has the following styles:
Title (centered)
Scene notations
Character Name

I choose Import Text in Script Format and Use Stylesheets. I uncheck Use Most Aggressive. Nothing else is checked. I click OK.

I first get an Identify the Style dialog. The style it is requesting me to identify is Note. I would have expected it to automatically identify a Note as a Script Note element, since Note is what appears in the element drop-down menu.

I choose Script Note and click OK.

The document opens. Every paragraph begins with \s0 or \S0. This is easily removed with Replace All, but I wonder why it's there in the first place.

Only the first paragraph with the style Note has been made a Note element. The remaining Note paragraphs variously become Shot, Character Name, In an attempt to work around this, I had reformatted the Notes in the original paragraph with line returns instead of paragraph breaks. However, the line returns get stripped out during import. I expect them to be retained.

The copyright symbol and em dash become question marks. This is odd, as I can insert these characters in the document.

Title (centered) becomes Shot.

Scene Notations becomes Shot.

A particular speech with multiple parentheticals originally got quite messed up. On my first try Parenthetical became Character Name, Action, Parenthetical, or Dialog; Dialog became Dialog, Character Name or Parenthetical. I find that by removing stray trailing spaces and tabs from the original that the recognition improves, but there is still one Dialog that becomes Character Name. (In my full document, there are a few such speeches, each encountering this problem.)

I also have some dialog requiring poetic line breaks. I tried this two ways in the source RTF file, once with line returns (shift-ENTER as one would do poetic line breaks within a MMS6 document) and once with return breaks (ENTER key).

The version with line returns were properly identified as dialogs, but the line returns were lost, so I would have to manually re-enter the line returns. As I have a play to be converted that has hundreds of such lines, this is not ideal.

The version with the return breaks changed the second and subsequent lines within each speech to Action. And, alas, as MMS6 tells me, I can't change the type of multiple elements, so each line would have to be changed manually as well.

So, I get that I have to have as clean a document as possible to get a good conversion. But what I would like to see improved would be:

- If I have an RTF document with styles properly identified, and have checked Use Stylesheet, then I expect MMS6 to retain all recognizable styles as they are in the imported document. If there are any discrepancies, those would be identified during SmartChek (which rocks, BTW).

- There needs to be a way to import poetic dialog and neither smoosh it together nor break consecutive lines apart.

- Keeping special characters such as copyright, em dashes, and ellipses would be nice.

- Converting smart quotes and apostrophes to dumb quotes and apostrophes would be nice, too, if you're not going to support them.

- Thorough documentation on how to create a clean, unambiguous RTF document for import, including a complete list of the proper style names to use that MMS6 will recognize.

The above is probably not going to prevent my purchase of MMS6 for future, but it does reduce the value of it for my existing scripts, particularly the more complex ones.

Technical Support
Posts: 73
Joined: Jan 25, 2008 5:23 pm

Re: Problems importing scripts

Postby KenTech » Nov 29, 2010 11:45 am

Can you try uploading the RTF again? The board is set to accept that file type. How large of a file is it? What happens when you try to upload?

Also, have you tried importing a plain text file instead of RTF to see if it's any better?
Ken H.
Write Brothers, Inc.
Technical Support


Re: Problems importing scripts

Postby ChasBelov » Dec 27, 2010 10:02 pm

I get "The extension rtf is not allowed." or "The extension txt is not allowed." The file is 66KB.

Importing as text gives the same problematic results as importing as rtf with Use Most Aggressive checked and Use Stylesheets unchecked.

Return to “Using Screenwriter”

Who is online

Users browsing this forum: No registered users and 0 guests